Calguns.net  

Home My iTrader Join the NRA Donate to CGSSA Sponsors CGN Google Search
CA Semiauto Ban(AW)ID Flowchart CA Handgun Ban ID Flowchart CA Shotgun Ban ID Flowchart
Go Back   Calguns.net > FIREARMS DISCUSSIONS > Shotgun discussions
Register FAQ Members List Calendar Mark Forums Read

Shotgun discussions Trap, Hunting, Defense and more. A place for enthusiasts to discuss the shotgun.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-10-2013, 9:01 AM
frenchy750's Avatar
frenchy750 frenchy750 is offline
Junior Member
 
Join Date: Jan 2013
Posts: 12
iTrader: 0 / 0%
Default New owner of Beretta A400 Xcel with a question

I bought a Beretta A400 Xcel and for the most part have been loving it, with one small problem. Before I get to that, just look at this beauty!





Let me start off by saying I am new to shotguns, and don't know proper terminology, but will do my best.

On to my problem... Very occasionally, a round will 'jam' on loading. i would say this happens once every twenty or so rounds. What happens is I drop a shell in the receiver, press the bolt release, and the shell doesn't quite seat properly. I have to push the bolt handle slightly to get the round chambered.

This happens when loading a single shell.

It was suggested the gun needed lubrication. The pro shop suggested Rem Oil and showed me the procedure. This helped, but I still experience the occasional 'jam' on loading.

It was also suggested the ammunition I was using wasn't 'strong enough' to properly cycle the gun. I have been using Fiocchi 2 3/4" 1oz. #8 target loads. I would understand there wasn't enough 'ooomph' if the shells weren't ejecting properly, but my problem is loading, the gun ejects the spent round just fine.

Is this a normal part of breaking in the gun? Should I try different ammunition to see if the gun just doesn't 'like' what I am currently using? Could something be slightly bent or out of adjutsment?

Any other suggestions?

Last edited by frenchy750; 03-11-2013 at 3:14 PM..
Reply With Quote
  #2  
Old 03-10-2013, 2:17 PM
ysr_racer's Avatar
ysr_racer ysr_racer is offline
Veteran Member
 
Join Date: Mar 2006
Location: somewhere lost in the O.C.
Posts: 4,055
iTrader: 4 / 100%
Default

How many rounds have shot thru it?

If you've put 1000 rounds thru it and it's still doing it, you have a problem. If you have less than 1000 rounds, keep shooting and try some different ammo.
__________________
Brad G.
So Cal USA
Check out my Sporting Clays page, CLICK HERE!!
Reply With Quote
  #3  
Old 03-10-2013, 2:31 PM
frenchy750's Avatar
frenchy750 frenchy750 is offline
Junior Member
 
Join Date: Jan 2013
Posts: 12
iTrader: 0 / 0%
Default

I've put 200 rounds through so far. I plan to put a bunch more through this week.

Any recommendations on different ammo to try? I'm mostly shooting sporting clays.
Reply With Quote
  #4  
Old 03-10-2013, 4:17 PM
ysr_racer's Avatar
ysr_racer ysr_racer is offline
Veteran Member
 
Join Date: Mar 2006
Location: somewhere lost in the O.C.
Posts: 4,055
iTrader: 4 / 100%
Default

I shoot Estate, but really just pull it apart, clean it, and shoot the crap out of it.

Ammo is pretty hard to find, but keep shooting it.
__________________
Brad G.
So Cal USA
Check out my Sporting Clays page, CLICK HERE!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -8. The time now is 6:37 PM.




Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Proudly hosted by GeoVario the Premier 2A host.
Calguns.net, the 'Calguns' name and all associated variants and logos are ® Trademark and © Copyright 2002-2016, Calguns.net an Incorporated Company All Rights Reserved.