Calguns.net  

Home My iTrader Join the NRA Donate to CGSSA Sponsors CGN Google Search
CA Semiauto Ban(AW)ID Flowchart CA Handgun Ban ID Flowchart CA Shotgun Ban ID Flowchart
Go Back   Calguns.net > VENDORS > Palmetto State Armory
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-18-2017, 12:22 PM
xlrting xlrting is offline
Junior Member
 
Join Date: Nov 2016
Posts: 26
iTrader: 0 / 0%
Default Issue with PSA 18" Rifle Length 223 Wylde Upper

PSA seems to have stopped answering emails since Christmas, so I'm hoping to get a response from PSA or anyone else who has experienced these issues.

Item 77932967

I received my new upper assembly on January 13 and shot it the next day using several different rounds. I discovered two issues:

1. IMI 5.56 55 gr: It shot and ejected normally, but I could not manually eject the round using the charging handle. It was stuck and I had to mortar it out. This happened every time using 3 different IMI rounds. No such problem with 223 rounds. Do you think this has something to do with the the Wylde barrel being out of spec for 5.56?

2. Norma USA 223 55 gr: I had consistent failure to feed. It looks like the bolt did not go all the way back. I'm using a carbine spring and buffer tube. No such issue with other 223 55 gr rounds (wolf, Pmc, IMI, American eagle) or the 5.56 IMI.
Reply With Quote
  #2  
Old 01-18-2017, 2:36 PM
Palmetto State Armory's Avatar
Palmetto State Armory Palmetto State Armory is offline
Vendor/Retailer
 
Join Date: May 2008
Posts: 894
iTrader: 13 / 100%
Default

Please include your order number, or IM it to me, and I will get your email resolved.
__________________
Palmetto State Armory
200 Business Park Blvd
Columbia, SC 29203
Web Sales: 803.788.9095
socialmedia.info@palmettostatearmory.com
Reply With Quote
  #3  
Old 01-24-2017, 9:48 AM
xlrting xlrting is offline
Junior Member
 
Join Date: Nov 2016
Posts: 26
iTrader: 0 / 0%
Default Contacted PSA

I missed the PSA response via this board so I bit the bullet and waited on hold. Their hold times are much shorter in the mornings (25 minutes) vs the afternoon (80 to 90 minutes). I am sending the upper back for inspection.

Last edited by xlrting; 01-24-2017 at 9:50 AM..
Reply With Quote
  #4  
Old 01-24-2017, 11:02 AM
uptown uptown is offline
Member
 
Join Date: Jul 2016
Posts: 212
iTrader: 0 / 0%
Default

Quote:
Originally Posted by xlrting View Post
PSA seems to have stopped answering emails since Christmas, so I'm hoping to get a response from PSA or anyone else who has experienced these issues.

Item 77932967

I received my new upper assembly on January 13 and shot it the next day using several different rounds. I discovered two issues:

1. IMI 5.56 55 gr: It shot and ejected normally, but I could not manually eject the round using the charging handle. It was stuck and I had to mortar it out. This happened every time using 3 different IMI rounds. No such problem with 223 rounds. Do you think this has something to do with the the Wylde barrel being out of spec for 5.56?

2. Norma USA 223 55 gr: I had consistent failure to feed. It looks like the bolt did not go all the way back. I'm using a carbine spring and buffer tube. No such issue with other 223 55 gr rounds (wolf, Pmc, IMI, American eagle) or the 5.56 IMI.

Interesting, let us know how it turns out and what they determine the issue to be. I'm interested in this upper as well.
Reply With Quote
  #5  
Old 02-02-2017, 7:52 AM
Arreaux's Avatar
Arreaux Arreaux is offline
Member
 
Join Date: Oct 2009
Location: Near Charming, CA
Posts: 395
iTrader: 0 / 0%
Default

Tag
__________________
_________________________________________

In an unarmed society, the armed criminal is king.
Reply With Quote
  #6  
Old 02-14-2017, 9:20 AM
xlrting xlrting is offline
Junior Member
 
Join Date: Nov 2016
Posts: 26
iTrader: 0 / 0%
Default

PSA got the rifle back on 2/2/17. I'm still waiting for an update from PSA. I just PM'd them.
Reply With Quote
  #7  
Old 02-14-2017, 10:30 AM
Palmetto State Armory's Avatar
Palmetto State Armory Palmetto State Armory is offline
Vendor/Retailer
 
Join Date: May 2008
Posts: 894
iTrader: 13 / 100%
Default

Your rifle is in the repair department having further testing done at your request through telephone.

Thank you for your patience.
__________________
Palmetto State Armory
200 Business Park Blvd
Columbia, SC 29203
Web Sales: 803.788.9095
socialmedia.info@palmettostatearmory.com
Reply With Quote
  #8  
Old 03-07-2017, 9:06 AM
xlrting xlrting is offline
Junior Member
 
Join Date: Nov 2016
Posts: 26
iTrader: 0 / 0%
Default

Status update for those following this thread.
1. 2/2/17 - PSA received my defective upper
2. 2/13/17 - I called for a status update. Was told rifle was firing correctly. I had to remind them to read my return instructions. The problem wasn't with firing; it was with manually ejecting the round. They agreed to conduct further testing.
3. 2/27/17- I PM'd for a status update. Was told they could not replicate the issue. However, they did not test using the 3 types of (extremely common) ammo I specifically called out in my return form.
4. 2/28/17 - Since PSA could not replicate or resolve the issue, I requested via PM for them to send it back and provide a tracking number.
5. 3/7/17 - It's been a week and no response. PSA has had the upper for 33 days. I'd be happy to take a refund if PSA would like to hang on to the upper.
Reply With Quote
  #9  
Old 03-07-2017, 9:10 AM
MotoFahren's Avatar
MotoFahren MotoFahren is offline
Senior Member
 
Join Date: Mar 2015
Location: Poootaaaatoooes
Posts: 707
iTrader: 6 / 100%
Default

Is this your first AR?
Did you clean and lube the rifle before use?
Completely disassemble, clean, and lube the bolt carrier group?
Clean the chamber?
Try another bolt carrier group?
__________________
"Simplify, then add lightness." - Colin Chapman
Reply With Quote
  #10  
Old 03-07-2017, 10:23 AM
xlrting xlrting is offline
Junior Member
 
Join Date: Nov 2016
Posts: 26
iTrader: 0 / 0%
Default Good suggestions

Good suggestions but not my first AR. I've shot 10 different brands of 223/556 out of this upper with the issue happening consistently with 3 brands--but IMI 5.56 is the worst offender. Interestingly, IMI 223 was fine.

I suspect the IMI 5.56 or the upper tolerances are just a bit off. If/when I get it back, I will definitely lube it up and shoot some more IMI 5.56 to maybe "smooth out" the problem areas. I've never experienced this with any ARs in the past in terms of the round being stuck and can't be easily manually ejected. I've fired hundreds of IMI 5.56 through other Wylde and 5.56 barrels with no issues.
Reply With Quote
  #11  
Old 03-16-2017, 10:29 PM
xlrting xlrting is offline
Junior Member
 
Join Date: Nov 2016
Posts: 26
iTrader: 0 / 0%
Default

Some people have asked me to post how this worked out so here it is. PSA stands behind it's product, but not sure if I'd buy again from them due to all the time I spent. I don't mind the long repair time, but the lack of information and misinformation was maddening.

1. 2/2/17 - PSA received my defective upper
2. 3/15/17 - Got it back via UPS
3. 3/16/17 - Took it to the range

Pros
1. It took awhile but they changed the barrel--definitely fixed the problem
2. The upper shot well before--the new one shoots just as well (1 MOA with Fiocchi 50 gr varmint round)
3. Very helpful people if you can make contact

Cons
1. Long repair time - 6 weeks
2. Extremely poor communication
a. Never answered emails
b. Responded to PMs for awhile then radio silence in the last 2 weeks
c. Phone waits times of 30 minutes on average
3. After several weeks of waiting without word, I requested a refund which they approved. After a few days, I called them again and they said the item was on its way back to me arrivng....TODAY (I never got a shipment notice AND there was no history of me requesting a refund).
4. Probably sent 4 emails, 8 calgun posts/PMs and 4 phone calls over 6 weeks.
Reply With Quote
  #12  
Old 04-27-2017, 10:12 AM
moonshade0227's Avatar
moonshade0227 moonshade0227 is offline
Junior Member
 
Join Date: Nov 2016
Location: Milpitas, CA
Posts: 82
iTrader: 2 / 100%
Default

Sounds like a headspace issue.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -8. The time now is 4:06 PM.




Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Proudly hosted by GeoVario the Premier 2A host.
Calguns.net, the 'Calguns' name and all associated variants and logos are ® Trademark and © Copyright 2002-2018, Calguns.net an Incorporated Company All Rights Reserved.