Calguns.net  

Home My iTrader Join the NRA Donate to CGSSA Sponsors CGN Google Search
CA Semiauto Ban(AW)ID Flowchart CA Handgun Ban ID Flowchart CA Shotgun Ban ID Flowchart
Go Back   Calguns.net > FIREARMS DISCUSSIONS > Rimfire Firearms
Register FAQ Members List Calendar Mark Forums Read

Rimfire Firearms .22, .17 and other Rimfire Handguns and Rifles

Reply
 
Thread Tools Display Modes
  #1  
Old 02-06-2013, 7:43 PM
rman's Avatar
rman rman is offline
Veteran Member
 
Join Date: Dec 2012
Location: San Diego County
Posts: 2,533
iTrader: 22 / 100%
Default M&p 15-22 + Magpul BAD, bolt issues

I installed a BAD, bent it to clear, and have an odd problem.

I've read about the bolt not holding open, but mine is a bit different. The bolt holds open on the last round, but i often pull the trigger again which dry fires the gun.

Anyone else experience this, or have any ideas?




Sent from my Apple Android
Reply With Quote
  #2  
Old 02-07-2013, 11:28 AM
loosewreck's Avatar
loosewreck loosewreck is offline
Veteran Member
 
Join Date: Jan 2008
Location: Los Angeles
Posts: 2,610
iTrader: 27 / 100%
Default

If the bolt is locked back, how is it that you are dry firing?

ETA: We'd really like to help; just that, so far your description doesn't make sense. Please describe what is occurring in better detail.
__________________
I don't measure a man's success by how high he climbs but how high he bounces when he hits bottom.
George S. Patton

It is impossible to defeat an ignorant man in argument.
William G. McAdoo

Last edited by loosewreck; 02-07-2013 at 11:41 AM..
Reply With Quote
  #3  
Old 02-07-2013, 11:54 AM
rman's Avatar
rman rman is offline
Veteran Member
 
Join Date: Dec 2012
Location: San Diego County
Posts: 2,533
iTrader: 22 / 100%
Default

Quote:
Originally Posted by loosewreck View Post
If the bolt is locked back, how is it that you are dry firing?

ETA: We'd really like to help; just that, so far your description doesn't make sense. Please describe what is occurring in better detail.
Sorry, i guess it's not "locking" back, rather is cocking after the last round then dry firing.

I've read somewhere about the bolt regular spring being too strong, and needing 2 coils cut. I'd want to source a replacement spring before cutting mine, though.

Sent from my Apple Android
Reply With Quote
  #4  
Old 02-07-2013, 11:59 AM
rman's Avatar
rman rman is offline
Veteran Member
 
Join Date: Dec 2012
Location: San Diego County
Posts: 2,533
iTrader: 22 / 100%
Default

Looks like this might be the fix

http://www.ar15.com/forums/t_3_15/59...=bottom#bottom

Sent from my Apple Android
Reply With Quote
  #5  
Old 02-07-2013, 12:06 PM
loosewreck's Avatar
loosewreck loosewreck is offline
Veteran Member
 
Join Date: Jan 2008
Location: Los Angeles
Posts: 2,610
iTrader: 27 / 100%
Default

Quote:
Originally Posted by rman View Post
Sorry, i guess it's not "locking" back, rather is cocking after the last round then dry firing.
Yeah, that sounds pretty strange. You should take the BAD lever off and see if it is still occurring without it.

Quote:
Originally Posted by rman View Post
I've read somewhere about the bolt regular spring being too strong, and needing 2 coils cut. I'd want to source a replacement spring before cutting mine, though.
I've read the same. This sounds like the right first course of action if you discover that it's the BAD lever that's causing the problem.
__________________
I don't measure a man's success by how high he climbs but how high he bounces when he hits bottom.
George S. Patton

It is impossible to defeat an ignorant man in argument.
William G. McAdoo
Reply With Quote
  #6  
Old 02-07-2013, 12:09 PM
INFAMOUS762X39's Avatar
INFAMOUS762X39 INFAMOUS762X39 is offline
Senior Member
 
Join Date: Jan 2012
Location: Southern San Andreas Fault
Posts: 1,437
iTrader: 1 / 100%
Default

My buddy installed a BAD lever on his LWRC M6, bolt held open after each shot. He soon replaced it with a BCM and the problem went away.
Reply With Quote
  #7  
Old 02-10-2013, 1:03 AM
rman's Avatar
rman rman is offline
Veteran Member
 
Join Date: Dec 2012
Location: San Diego County
Posts: 2,533
iTrader: 22 / 100%
Default

Figured it out.... 2 things.

#1 trimmed a coil off the bolt catch spring
#2 had to bend (a lot) to clear the mag catch. When dropping the mag, it would hit the lever and release the bolt

Sent from my Apple Android
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -8. The time now is 9:35 PM.




Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Proudly hosted by GeoVario the Premier 2A host.
Calguns.net, the 'Calguns' name and all associated variants and logos are ® Trademark and © Copyright 2002-2016, Calguns.net an Incorporated Company All Rights Reserved.