Calguns.net

Calguns.net (http://www.calguns.net/calgunforum/index.php)
-   FFL's Forum (http://www.calguns.net/calgunforum/forumdisplay.php?f=168)
-   -   ATF EZ Check: 413 Request Entity Too Large ????? (http://www.calguns.net/calgunforum/showthread.php?t=674818)

ptoguy2002 01-09-2013 3:13 PM

ATF EZ Check: 413 Request Entity Too Large ?????
 
I've sold a receiver, and have the FFL's info, tried checking yesterday and today, and keep getting:

Quote:

413 Request Entity Too Large
HTTP/1.1 413 Request Entity Too Large Date: Wed, 09 Jan 2013 23:07:49 GMT Server: Oracle-Application-Server-10g Connection: close Transfer-Encoding: chunked Content-Type: text/html; charset=iso-8859-1
Request Entity Too Large
The requested resource
/fflezcheck//fflSearch.do;jsessionid=0afbfaf930d73532f8d08ae947 ddb6e193478ff30972.e34PaNePb3iTb40LbhqSaN0Rc3n0
does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.

Additionally, a 413 Request Entity Too Large error was encountered while trying to use an ErrorDocument to handle the request.

First time I've ever had a problem.
Anybody ever run across this?
Server problem?
High demand?
Wait?

Toby's Tactical 01-09-2013 3:27 PM

I saw this yesterday also. Couldn't get a different result.

lazyworm 01-09-2013 3:27 PM

I don't know about the ez check site, but this error usually means there
is a problem between your browser and that web server.

Try...
* completely clear the forms, re-type all the info and resubmit -- it's possible you have cut-n-pasted too much into the form
* restart browser
* different browser
* flush cache
* different computer

ptoguy2002 01-09-2013 3:31 PM

Tried again (multiple times), and it worked finally.
I think their server is busy.

67goat 01-09-2013 4:05 PM

This is a generic (though fairly uncommon) error describing a connection issue between your browser and their database (I'm not an ffl, but I know a thing or two about web programming).

As more than one person reported this and you didn't say this form was significantly different than others you have submitted, it was most likely on their end. The server being busy could be the reason, but a request timeout error is more common for that. It could also have been that they changed a parameter on that page incorrectly and caused data to be submitted incorrectly. We had a situation at work the other day where certain pages would not work for people logged in with usernames that had a space in them. We made a change and forgot to properly parse usernames, the spaces then broke the code. They could have also made a change that altered how the page excepts data (there are two methods, GET & POST, and they can't always be used interchangeably).

There are only four things you can really look at on your end if that particular error happens. Clear your cache and cookies, make sure there are no fields that exceed the maximum length allowed, no files attached larger than allowed (don't even know if that is possible in this instance), and completely close all browser windows then restart the browser (not the computer, just the program). The last step would close any sessions you had running ang create new connections to any site you were using. The cookies and uploaded files are the most likely culprit if the error is from the client side (your browser). The field length issue is possible, but a stretch (normally this would be a different error, but could be depending on how they coded the page). If all of those are fine on your end, then the error is their system and is not really specific enough to tell you what it is. Also there would be nothing you could do but wait to see if it resolves or contact them to let them know. In this case it seems to have resolved (at least for now).

Web errors (404, 500, 413, etc...) are generally about as useful as you telling you doctor you have a cough. This one has a little more info that would allow somebody with direct access to the server to get a little more info, but it would also be cryptic and mostly useless.

Librarian 01-09-2013 4:17 PM

Quote:

Server: Oracle-Application-Server-10g Connection: close Transfer-Encoding: chunked Content-Type: text/html; charset=iso-8859-1
Request Entity Too Large
says it's an Oracle database error returned because the web app tried to pass it something it didn't like.

The web app detects the Oracle error, and generates its own set.

In this case, I'd say the same as all the first-line (rabbit) tech support people do - 'have you closed and restarted your program? Have you rebooted your computer?'

('rabbit' is a 'get there quick' technician; service contracts usually have a minimum response time in them - one pays more for shorter time [extreme version is a tech that lives at your site 24/7]. Doesn't matter to the contract terms if the person who shows up can't fix the problem, some body showed up to meet the response time.)

67goat 01-09-2013 8:41 PM

The "Request Entity Too Large" part of that is not an Oracle message. It's an HTTP error description for a 413 error. It does not indicate specifically that it is a database error (though it very well could be). It is a web application error page used for debugging. The web app should be configured so an end user never sees that message (can give too much information about system design and connection settings). Any error page for a web app will show a connection line like that. Our debug pages show a MSSQL line even when the error is a code issue and not a database error, but we use a custom error page so the user would never see that line.

TRICKSTER 01-09-2013 9:35 PM

You can always look it up manually.
http://www.atf.gov/about/foia/ffl-list-2012.html

Librarian 01-09-2013 9:55 PM

The actual Oracle message appears to be
Quote:

DRG-11832 Request Entity Too Large
Cause:

Request rejected because request entity is too large (HTTP_ERROR = 413).
http://ora-messages.adgoogy.com/DRG-11832

Sigh; typical damned error message. Once had a DB throw an error substantially 'this should never happen'; printed my screen, took it down to the developer, and said, 'So, Ed, about this message ... '. Worked for Ingres, Sybase, Informix in software testing in a previous life.


All times are GMT -8. The time now is 7:54 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.