PDA

View Full Version : What wrong with my AK?


AK4me
04-21-2008, 8:10 PM
It is a new Romanian G. The first time I shot it I didnt have a mag and just loade them one at a time 40 total with no problems. The next time I took it out I had a mag and every 2nd or 3rd shot it went click and no bang, When I ejected the round I could see the firing pin barely hit the primer when I tried them again they fired ok, could it be the mag or maybe a weak mainspring?

MrTuffPaws
04-21-2008, 8:19 PM
Check the bolt and make sure that the firing pin moves freely and sticks out the back of the bolt with a round in the chamber.

You might have a malformed firing pin, or the channel is dirty or has a burr.

USN CHIEF
04-21-2008, 8:22 PM
Maybe is the Wolf Ammo:eek::rolleyes: No but for real, have you tried a different batch of ammo, it could be the ammo that you are using is bad..

AK4me
04-21-2008, 8:25 PM
The ammo I used was Fiocchi 143gr FMJ, Ill check the firing pin.

JHC
04-21-2008, 8:55 PM
Who built the rifle? Alot of guys that are putting these together cure bolt to hammer hangup on new rifles by grinding a little material from the hammer face but sometimes they go too far down and get into the area that contacts the firing pin.

oaklander
04-21-2008, 9:00 PM
When you say "click" - you mean that the hammer is falling and striking the firing pin???

If not - you could have a hammer follow issue.

It is a new Romanian G. The first time I shot it I didnt have a mag and just loade them one at a time 40 total with no problems. The next time I took it out I had a mag and every 2nd or 3rd shot it went click and no bang, When I ejected the round I could see the firing pin barely hit the primer when I tried them again they fired ok, could it be the mag or maybe a weak mainspring?

1lostinspace
04-21-2008, 9:27 PM
Firring pin- Head space-Bad ammo-bad mag not letting the bolt close all the way. If the rounds worked good with out the mag I don't think it's the ammo or pin.

sloguy
04-21-2008, 9:33 PM
is the bolt or bolt carrier( i donno what contacts what) is anything rubbing against the magazine lips? that could cause the bolt to not get closed completely. look for shiny spots on the magazine lips. mark em with a sharpie and try working the action and look for the sharpie to be worn away.

scotthmt
04-21-2008, 11:24 PM
Im putting my money on the hammer spring in backwards. Have pics of the gun's guts? or the ammo?

AK4me
04-22-2008, 5:39 PM
Firring pin- Head space-Bad ammo-bad mag not letting the bolt close all the way. If the rounds worked good with out the mag I don't think it's the ammo or pin.

Thats what I am thinking, The pin moves freely I even took the bolt to work today and blew it out with the air hose to make sure it was clean, I am kind of thinking it is the mag which fits nice and tight but may be rubbing and not letting the bolt close all the way like sloguy said, the first shot was always fine because I closed the bolt myself it was the 2nd or 3rd shot where the firing pin wouldnt strike the primer hard enough, I was going to take some pics of the hammer spring but my camera needs to charge, Ill post them in a little while, My rifle came from Henderson Defense, I dont want to call them until I know for shure its the rifle and not the mag , those guys at HD were cool, I would buy from them again.

AK4me
04-22-2008, 8:29 PM
Here are pics of the hammer ang firing pin,
http://usera.imagecave.com/snotrag3/myak001.jpg
http://usera.imagecave.com/snotrag3/myak002.jpg
I ordered another mag(One of the 10/30rd promags) and some wolf ammo, Im going to try it out this weekend.

mason1800
04-22-2008, 11:47 PM
pull the trigger and hold, then cycle the bolt carrier. you should hear two clicks all the time. once when you release the trigger (disconnector)and the other when you pull it again(trigger) . i had the same problem and it was hammer follow.

oaklander
04-22-2008, 11:50 PM
I'm voting hammer follow too.

AK4me
04-23-2008, 10:31 AM
Hammer Follow? What it that?
And how do I fix it?
Do I have to send it back?
Thanks for all your help guys.

phsieh10
04-23-2008, 11:16 AM
I had a problem where the hammer was following the bolt after one shot because the trigger wasn't resetting all the way. I have an after market PG that was causing the trigger to hang up on the PG. I shaved a bit of material from the PG and fixed the problem. From your pictures, it looks like you don't have a PG. I have an NDS3 receiver with a romyG kit.

AK4me
04-23-2008, 4:40 PM
I had a problem where the hammer was following the bolt after one shot because the trigger wasn't resetting all the way. I have an after market PG that was causing the trigger to hang up on the PG. I shaved a bit of material from the PG and fixed the problem. From your pictures, it looks like you don't have a PG. I have an NDS3 receiver with a romyG kit.

I hate to sound like noob but what is a PG?
My reciever is also nds3.

scotthmt
04-23-2008, 8:35 PM
PG = pistol grip?

Did your AK fail the function test? (hold trigger and rack slide, listen for 2 clicks)

AK4me
04-23-2008, 10:48 PM
PG = pistol grip?

Did your AK fail the function test? (hold trigger and rack slide, listen for 2 clicks)

No, I heard 2 clicks. Im going to try again this weekend with a different mag and different ammo.