PDA

View Full Version : Failure to feed with Spikes Tactical .22lr upper.


frigginchi
11-18-2007, 6:01 AM
I'm having trouble with rounds jamming and the bolt not going all the way into battery. I've tried all kinds of ammo. Any ideas guys?

Cobrarlc
11-18-2007, 6:43 AM
How many round have you put thru the upper? Spike recommeds keeping the bolt wet with "Tri-Flo" for the first couple of hundred rounds. Also recommeded is after about a hundred of rounds is to remove the bolt and spray it down with brake cleaner to remove any fouling, then respray with "Tri-Flo". There is a break in period as stated by Spike. Also Wal-Mart Federal 550 packs seem to work the best.
If all else falls give Spike a call and ask for tech support.

Solidsnake87
11-18-2007, 10:04 AM
Have you tried CCI .22lr mini magnums? If it won't feed with those then definitely contact spikes!

frigginchi
11-18-2007, 1:13 PM
cci mini mags. yello jackets, viper, eloy tenex, other cheap stuff that is in the bottom of my range bag. the 10/22 swallows these up fine.

paradox
11-18-2007, 2:10 PM
Does Spike’s polish their ciener kits?

I have a stand alone ciener kit that needed to be heavily filed, stoned, and polished in order to slide freely. Now it eats everything short of Colbri primer only ammo.

mason1800
11-18-2007, 3:19 PM
I also, just took out my new Spike's Tactical upper and it shot without a flaw. I used Aguila ammo, shot about 300rd and no jams or dead ammo. You really need to keep the bolt wet for the first few hundred rounds.

frigginchi
11-19-2007, 9:55 AM
I would love to get a few hundred rounds through it if it didn't jam every other round.

I also, just took out my new Spike's Tactical upper and it shot without a flaw. I used Aguila ammo, shot about 300rd and no jams or dead ammo. You really need to keep the bolt wet for the first few hundred rounds.

JALLEN
11-19-2007, 1:20 PM
I took mine out to the range last week to see if it worked after putting it all together, and it fired 100 rounds, using the BDM 10 round mags, without hitch or hiccup. I will take it out to zero the sights at 50 yards soon, but so far, there have been no problems at all. All the rounds were on the paper at 25 yards, and most of them actually close to the 10 ring! I was using Federal ammo from Walmart.

gose
11-22-2007, 8:51 PM
I'm having trouble with rounds jamming and the bolt not going all the way into battery. I've tried all kinds of ammo. Any ideas guys?

I had the same issue with mine, once or twice / mag with CCI minimags. Federal Am Eagle seemed to work slightly better, but it was still there.

Got the upper Wed, so only had time to put a couple of hundred rounds through it. Bought a few other brands to try and will give it a good cleaning before I try again as well.

PLINK
11-22-2007, 9:08 PM
Mine did not like Remington Golden Bullets. Wally World Federal bulk pack, CCI mini mags, and Velocitors all work 100%.

Try to hand feed the round into the chamber. If the round does not go in smooth then I may not feed correctly. This is what happened with the RGBs in my case. I could not even get the bolt to close with RGBs.

OpticsPlus
11-22-2007, 9:29 PM
I took my Spikes .22lr upper from the box to the range and fired over 1k rounds through it with no hiccups at all. Give them a call and see what they say.