PDA

View Full Version : What's wrong with my 930 SPX?!?! *UPDATE*


FLAWLS1
09-10-2012, 1:46 PM
So last night I took it apart to do a normal rub down with oil and I put it back together. I loaded up the magazine tube before I re-installed my Nordic clamp/rail. Loaded 7 perfectly fine, then I installed the Nordic clamp and loaded the magazine tube again and the follower and spring gets jammed up in the tube. What the hell!! This is the first time I've experienced this and this.

I had a buyer who was going to buy this, but I will not sell a firearm that doesn't function like it should. I took apart the SPX 5 times to check for anything abnormal, but nothing. The follower is in correctly and there are no kinks in the spring. It seems to happen only when the Nordic clamp is installed. Also, it's only letting me fit 6 shells vs 7 AND 7 shells fit fine when the Nordic clamp isn't on. What could this be? This shotgun only has 90-100 rounds through it too. I checked the magazine extension and it doesn't look crooked or dented. It screws on fine just like it did when it was new.

CasperSYTFU
09-10-2012, 1:50 PM
Sounds like the spring isn't seating correctly in the end of the tube.
Especially since you lost 1 round out of the capacity.
I run the same clamp, but what follower are you using?

jessegpresley
09-10-2012, 2:02 PM
Could the Nordic clamp be clamping too hard on the tube, constricting it ever so slightly?

FLAWLS1
09-10-2012, 2:02 PM
Sounds like the spring isn't seating correctly in the end of the tube.
Especially since you lost 1 round out of the capacity.
I run the same clamp, but what follower are you using?

I still have the factory follower. I just don't understand how out of no where this is happening now. And to only happen when the clamp is installed. When it's jammed up there, as soon as I start to loosen the clamp the spring/follower un-jam and go back to normal.

FLAWLS1
09-10-2012, 2:03 PM
Could the Nordic clamp be clamping too hard on the tube, constricting it ever so slightly?

That's what my thoughts are, BUT I always clamped it down pretty tight with no problems at all until now. It doesn't look to be clamped down tight enough where it squeezes the extension tube.

97F1504RAD
09-10-2012, 2:06 PM
Obviously it is the Nordic Clamp since the issue goes away once you loosen or remove it. It is somehow compressing the mag tube enough to cause this issue Try moving the clamps around in a few different positions and see if anything changes. Is it possible that one end of the clamp has a smaller diameter and you have it swapped?

FLAWLS1
09-10-2012, 2:13 PM
Obviously it is the Nordic Clamp since the issue goes away once you loosen or remove it. It is somehow compressing the mag tube enough to cause this issue Try moving the clamps around in a few different positions and see if anything changes. Is it possible that one end of the clamp has a smaller diameter and you have it swapped?
No, the clamp is on the right way.

RippSpeed
09-10-2012, 5:07 PM
Look @ you main tube ... see if there's any burrs or bents on the lips that causes hang ups. And check you follower as well for any burrs.

Lastly I add a little film of oil on the follower and the main tube and the extension. And run the a clean patch thru it...

hope this helps... I've experience this before and its usually burrs, dirty tube or bent spring

Standard
09-10-2012, 5:41 PM
It's the clamp. I had the same issue on my 500 using an elzetta light mount. Loosened it slightly and it was fine.

Dellinger
09-10-2012, 9:28 PM
Check with the Nordic Components sold on the Cactus Tactical websight. They say if your using this clamp on a 930SPX or a 590 you need the heavy barrel clamp, just make sure the company you ordered it from sent the correct part(clamp made for the 930SPX or 590 only) or that you didn't order wrong. The smaller clamp will do what you are describing and you would not be the only guy on the web with the same issue.

mudbass7
09-11-2012, 2:00 AM
Sounds like the spring isn't seating correctly in the end of the tube.
Especially since you lost 1 round out of the capacity.
I run the same clamp, but what follower are you using?

I run the same clamp as well with the stock follower.
But to my knowledge, the gun only holds 7+1 anyway right?

FLAWLS1
09-11-2012, 3:39 AM
Ok, I solved the problem! I couldn't help but think about this problem while at work today so when I had the free time I pulled out the SPX and started to inspect it (Nordic clamp was on). After about 5 minutes looking at it carefully I noticed that the magazine tube was just slightly bent downwards. I slowly started to loosen the clamp and I noticed as I loosened it, the magazine tube started to straighten.

After the clamp was off I screwed down the magazine tube as hard as possible. I reinstalled the clamp slowly watching to make sure it didn't bend the tube downward again. I got it pretty tight, but not as tight as it was when it was causing these problems. I did a function check (loading 7 shells in tube) about 10 times making sure it didn't jam and it now works like it did before!! Maybe the factory Choak tube is a POS after all. If I decide to keep this I'm definitely going to get a Nordic +2 extension tube.

Bobby Hated
09-11-2012, 6:48 AM
those clamps also throw the barrel off a little so slugs hit off from where they do without the clamp.

Standard
09-11-2012, 8:02 AM
I'll take the choate off your hands if you upgrade.

Mp5marley
09-15-2012, 5:51 PM
What's a choate? I just put my spx in jail today and so I am researching as much as I can for the next 9 days... I figured out what a nordic +2 tube is but what is a choate?

RippSpeed
09-15-2012, 5:54 PM
What's a choate? I just put my spx in jail today and so I am researching as much as I can for the next 9 days... I figured out what a nordic +2 tube is but what is a choate?

Choate is the manufacturer of the pistol grip and extended tube on the spx

RippSpeed
09-15-2012, 5:57 PM
Ok, I solved the problem! I couldn't help but think about this problem while at work today so when I had the free time I pulled out the SPX and started to inspect it (Nordic clamp was on). After about 5 minutes looking at it carefully I noticed that the magazine tube was just slightly bent downwards. I slowly started to loosen the clamp and I noticed as I loosened it, the magazine tube started to straighten.

After the clamp was off I screwed down the magazine tube as hard as possible. I reinstalled the clamp slowly watching to make sure it didn't bend the tube downward again. I got it pretty tight, but not as tight as it was when it was causing these problems. I did a function check (loading 7 shells in tube) about 10 times making sure it didn't jam and it now works like it did before!! Maybe the factory Choak tube is a POS after all. If I decide to keep this I'm definitely going to get a Nordic +2 extension tube.

If you get the Nordic extended tube get the +2 with the XL end cap ... this will give you 8 in the tube with the nordic spring or factory spring. And will be flush. Add the XXL 1 1/2" will give you +2 ... But will be way past the muzzle.

heres M24Shooter's Spx w/ a XL end cap:
http://i15.photobucket.com/albums/a391/m24shooter/930%20update/extcapwm.jpg

FLAWLS1
09-15-2012, 6:55 PM
If you get the Nordic extended tube get the +2 with the XL end cap ... this will give you 8 in the tube with the nordic spring or factory spring. And will be flush. Add the XXL 1 1/2" will give you +2 ... But will be way past the muzzle.

heres M24Shooter's Spx w/ a XL end cap:
http://i15.photobucket.com/albums/a391/m24shooter/930%20update/extcapwm.jpg

Cool, that's good to know! If I keep it I was already planning to get that Nordic tube.