PDA

View Full Version : Need your advice on my 870


Fliggidy
06-02-2012, 7:45 PM
Not to long ago a friend of mine gave me his Rem 870 Express.

He said it doesn't feed well. So Since all I had to pay was the $35 Dros I took it.

He was right, when I put 7 rds in the first 2 would feed, but the rest seem to not feed. It looks like the spring is getting hung up somewhere or the spring is weak now. :helpsmilie:
Since the spring is also getting hung up, would anyone know where it would be getting hung up on?

I'd like to know if anyone has had the same problems with theirs and what their solution / fix was?
Also what's a good spring kit with follower to get?

Thanks a bunch guys.

aippi
06-02-2012, 7:52 PM
Since you say seven rounds I assume you have a 20 barrel and Remington three shot extension on it.

Your problem is the tube extension is not installed properly. Go to www.aiptactical.com and read the red link "Install and cleaning" or watch the How to video on the same web site on how to properly install the tube extension. Do this and your problem is over.

Fliggidy
06-02-2012, 8:23 PM
Since you say seven rounds I assume you have a 20 barrel and Remington three shot extension on it.

Your problem is the tube extension is not installed properly. Go to www.aiptactical.com and read the red link "Install and cleaning" or watch the How to video on the same web site on how to properly install the tube extension. Do this and your problem is over.

I'll give check it and and try it out....

CROSSING FINGERS....

plug ugly
06-03-2012, 5:52 PM
+1 on bad install/ wrong spring. here is a vid that may help.

http://www.youtube.com/watch?v=m-ztzICm5lg

NewbieDave
06-03-2012, 8:34 PM
Take the pump off and also see if the mag tube is aligned or if there's dent.

CK_32
06-03-2012, 8:49 PM
Did he sand downthe dumples properly? If it was a 4+1?

Fliggidy
06-05-2012, 4:20 PM
Got it to pump and cycle now. It looks like I'm going to need to replace the follower. Spring feels good. But will replace it as well. There was nothing to shave off or punch out on mine. When I took it apart it seemed that the extension tube was off center. Cycled with a full mag about 5 times and no hang ups. For now that is. Until I'm 100% comfortable I'll be using my mossy as my primary HD.