PDA

View Full Version : Stag Disconnector Gouge?


AirShark
05-31-2012, 9:21 AM
Hi all,

I'm putting together my first AR and I noticed that the disconnector included in my LPK from Stag Arms has a gouge or something across the top edge across the whole part. Maybe just a casting mark?

It completes a function check normally and the trigger feels great to me.

I emailed Stag on 5/26 but got no response. I called them today and they told me that sometimes it happens and left it at that.

I thought I'd ask for the opinion of you Calgunners instead of continuing to lurk around here :) I guess I'm just concerned with any potential long term issues. I realize it's probably fine, its just that being it's my first time assembling I want to be sure.

Take a look and let me know what you all think, thanks in advance!:

http://webpages.charter.net/airshark/images/ar/20120526_094906.jpg
http://webpages.charter.net/airshark/images/ar/20120526_095004.jpg

killshot44
05-31-2012, 8:05 PM
Not the nicest cut from the machine but it's not going to weaken it or anything. As long as it feels smooth and functions......use it.

gunnerstuff
05-31-2012, 9:18 PM
Yea, looks like standard tooling marks. Have seen that to varying degrees. A bit on the excess side from your pics, but it does not hinder the performance of the disconnector

shadowofnight
05-31-2012, 10:31 PM
Seen worse, that should be fine.

Xingu
05-31-2012, 10:35 PM
Perfectly normal.

6mmintl
06-01-2012, 6:15 AM
The mark or crack that you believe is defective is not a problem, the disconnector is a stamped part from a sheetmetal strip and the edges of the die are worn causing the material (edges) to drag/scrape metal across the edge as opposed to cleanly cut/shear the metal.

AirShark
06-01-2012, 10:35 AM
Thanks guys for all of the great responses. I'll put the OCD back in it's cage lol.

I'm glad this website is here for us!