PDA

View Full Version : AK QUESTION!?!?!


ACRfan
05-23-2012, 11:09 AM
I have a home built AK and it wont feed anything with a polymer mag.. Standard steel mags work fine but as soon as a polymer mag is inserted the feeding problem starts.. I have tryed arsenal, tapco and promag polymer mags all with the same results.. Feeds round half way in then jams up..

What would cause this??

Travis590A1
05-23-2012, 11:30 AM
A bad ak! Lol no seriously check your feed ramp and bolt to make sure they are grabbing the round from the mag. Start small

ACRfan
05-23-2012, 1:08 PM
It grabs te round out of them but it jams up..

But the metal mags have zero problems..

chead
05-23-2012, 1:13 PM
Did you try using the springs from the steel mags in the polymer?

ACRfan
05-23-2012, 1:31 PM
A tapco a arsenal and a promag all need new springs?

chead
05-23-2012, 1:40 PM
I doubt it, I'm suggesting you check the springs between them. The spring in a surplus mag is going to be a lot different than what you'll find in a new production mag. If you swap the springs, you may be able to narrow down the issue.

FiveSeven
05-23-2012, 1:48 PM
AK is not built properly and/or out of spec.
I know someone with homebuild who chewed up (destroyed) Tapco magazines (my primary range mags)......never had issue with same mags trough any Saiga.

alfred1222
05-23-2012, 1:52 PM
Why don't u just use the metal mags??? And I think the mag is sitting low as well

ACRfan
05-23-2012, 1:53 PM
Is there anyone in SoCal (oc, Ontario) that can check it out

chead
05-23-2012, 1:54 PM
I'll probably be at the range this weekend in San Diego, PM me if you want to meet. I've got steel and polymer, we can trade for a few rounds and see what happens.

Richard Erichsen
05-23-2012, 4:02 PM
Is there anyone in SoCal (oc, Ontario) that can check it out

Contact Roccobro by PM. He's located in San Bernardino and can help you.

R