PDA

View Full Version : Bushmaster Predator FTF first time out


TheExiled
04-13-2012, 8:08 AM
http://i176.photobucket.com/albums/w163/five56nato/2012-04-12_14-21-21_684.jpg

Brand new Predator upper, first time out. All day I think he had 12 FTF and one double feed. Sighting in the scope at 50 yards and this happened about every mag and a half, Using PMag10/20 and then tried my 10/30 with the same result

Most of the problems were with Federal 55gr's, but he had one or two with Remington HP's(out of 20), but fired 50 Hornady Steel Match without a hiccup. I used his mag with his Federal and my gun swallowed it without a hitch


Thoughts? Carbine buffer the problem, gas system not correct, bad ammo?





Edit: Yeah I lift a lot, ignore the hands

TheExiled
04-13-2012, 8:14 AM
And the gun pron cause i know everyone enjoys some

http://i176.photobucket.com/albums/w163/five56nato/2012-04-12_14-06-45_45.jpg

http://i176.photobucket.com/albums/w163/five56nato/2012-04-12_14-06-20_889.jpg

TheExiled
04-14-2012, 10:37 AM
Bump for the saturday crowd's opinions?

Prc329
04-14-2012, 11:20 AM
Looks like the bolt was missing the rim of the case and hitting further up the casing. I had issues with 10/20 Pmags till I switched to the magpul limiter. Not sure about the 30s.

FeuerFrei
04-14-2012, 11:22 AM
double feed is usually a mag problem.
HP ammo can give fits to an AR.
works with buddy's mag, problem solved.
lots of 10/20 and 10/30 mags are NOT done right and can create problems for the user.
most just use a cut up kitchen cutting board made into small squares that go inside the mag and "gomered" together with glue/rivets etc..
caveat emptor
nice rifle btw.

TheExiled
04-14-2012, 11:26 AM
I was thinking it was a problem with his 10/20, but like I said it happened with my 10/30 in his gun too, and his 10/20 worked perfectly in my gun.

The HPs actually were the ones that worked better, although I figured because maybe they were hotter loads (Hornady Steel Match)

baih777
04-14-2012, 1:09 PM
are there any marks on top of the mag from the bolt hitting it ??

Sturnovik
04-14-2012, 2:19 PM
Looks like the bolt was missing the rim of the case and hitting further up the casing. I had issues with 10/20 Pmags till I switched to the magpul limiter. Not sure about the 30s.

I'm new to rifles, being a pistol/shotgun guy and all. But I would think your right.

Took out my first AR a month ago, had EXACTLY the same looking brass issues and I took one of the 10/20's out of rotation.......no more issues. Who knows.

proclone1
04-14-2012, 2:55 PM
I'm new to rifles, being a pistol/shotgun guy and all. But I would think your right.

Took out my first AR a month ago, had EXACTLY the same looking brass issues and I took one of the 10/20's out of rotation.......no more issues. Who knows.

Just to chime in, I use 10/20 & 10/30 pmags with my ACR, and it has a bunch of issues with ammo being pinched just like the OP's. I use the magpul 10/20 limiters (with a rivet in the locking plate for "permanence"), and then magblock* 10/30 limiters (also w/ rivet in locking plate). With the ACR, however, I suspect that a huge culprit is the maglock. That thing seriously sucks, and AFAIK there's no alternative to the assault-planet version. The lil set-screw on the right-side eventually screws itself loose, to the point that it becomes very difficult to tool-eject a magazine (luckily, you still need a tool, so no legality issues). I suspect that this looseness issue is also playing games with ammo-feeding and the subsequent problems.