PDA

View Full Version : Glock 34 Slide Issue (user error!!!!)


Chuntsman949
02-24-2012, 6:16 PM
Hello!

I have had my g34 for 2 years and have had zero issues... Today I installed the ny1 trigger and LWD Connector... after assembly it feels like my slide is getting stuck/is rough when I rack it... there is somthing catching on the slide and I dont know what it could be... do any of you gents have an idea? I looked at it field stripped side by side with my g19 and cant figure it out...could it be getting hung up on the rear of the trigger bar that sits on the ny1?


Thanks!!

gotshotgun?
02-24-2012, 6:24 PM
Disassemble everything and reassemble, you likely just installed something incorrectly.

Chuntsman949
02-24-2012, 6:28 PM
Disassemble everything and reassemble, you likely just installed something incorrectly.

Ive already gone that route I am seriously stumped....

HighLander51
02-24-2012, 6:31 PM
I have had my g34 for 2 years and have had zero issues...

So, why did you change anything? What did you think you would gain?

How often did you shoot the G34 in the last 2 years?

Chuntsman949
02-24-2012, 6:34 PM
I have had my g34 for 2 years and have had zero issues...

So, why did you change anything? What did you think you would gain?

How often did you shoot the G34 in the last 2 years?

easy chief... I wanted to get more positive reset in the trigger so I added the ny1 spring and 3.5 connecter to try it out... I have put thousands of rounds down range with the g34 and I shoot it at least twice a week with my g19... what was the point of this post sir? I need help not a dressing down.

kedenimar
02-24-2012, 6:43 PM
sounds like the misalignment of parts...maybe the trigger spring is installed incorrectly? did they possibly ship you the wrong part?

cranemech
02-24-2012, 6:45 PM
Don't know squat about these guns. But are the changes you made irreversible? Can you change one item at a time to see which part is causing the bind?

Kodemonkey
02-24-2012, 6:51 PM
Check your slide catch spring. It needs to go under the pin. That's one common re assembly issue.

http://img.tapatalk.com/6297f327-5a4f-757a.jpg

Also, including the top down pic from my G35 to show alignment if that helps.

http://img.tapatalk.com/6297f327-5aa5-a00a.jpg

My guess is that it is the ejector running against something. But it could be a bent connector.

Chuntsman949
02-24-2012, 7:36 PM
thanks dude the spring is under the pin. it looks like the ny1 raises the top of the trigger bar which covers the ny1 spring...looks like this

http://i44.tinypic.com/iynfb7.jpg

gmeister
02-24-2012, 7:49 PM
Your ejector looks bent in the photo.

MyGlock17
02-24-2012, 7:50 PM
try putting the old one back in see if does the same thing...

MXRider
02-24-2012, 7:55 PM
It's the lone wolf connector, I have one as well and it makes the slide harder to rack in all three of my Glocks. Needless to say it stays in the parts bin and will never get used. The factory Glock "minus" connector works much better.

Chuntsman949
02-24-2012, 7:57 PM
It's the lone wolf connector, I have one as well and it makes the slide harder to rack in all three of my Glocks. Needless to say it stays in the parts bin and will never get used. The factory Glock "minus" connector works much better.

I see, Will it cause failures of any kind?

Andric
02-24-2012, 7:57 PM
Just looked at mine and the trigger bar does look bent up at the back more than normal, it should be flat. Cna you take a shot from the back looking at it level.

MXRider
02-24-2012, 8:04 PM
Don't know, never fired it. I also got a ghost connector and that one sucks as well. My advice is to stick to factory Glock parts.

Oceanbob
02-24-2012, 8:09 PM
Wondering if you touched the slide..?. Once I had an issue like you describe and the firing pin safety plunger spring was in sideways. Just wondering.

Be well, Bob

Chuntsman949
02-24-2012, 8:15 PM
wow put the oem - in works like a charm.. thanks guys

MXRider
02-24-2012, 8:25 PM
How do you like the NY1 with the minus connector? I want to give that combo a try.

Chuntsman949
02-24-2012, 8:49 PM
it feels very nice, I cant wait to put rounds down range tomorrow

scglock
02-25-2012, 12:41 AM
Your ejector looks bent in the photo.

I believe ejectors depend on the caliber. They have straight ones and ones with a slight bend

HighLander51
02-28-2012, 5:27 PM
easy chief... I wanted to get more positive reset in the trigger so I added the ny1 spring and 3.5 connecter to try it out... I have put thousands of rounds down range with the g34 and I shoot it at least twice a week with my g19... what was the point of this post sir? I need help not a dressing down.

Only trying to figure if you ran the G34 for thousands of rounds with OEM parts and no problems, like you stated, then the mods cause problems, that's all. It's best to only change one single part at a time. I see lots of new shooters in competition that have changed out parts before running the gun stock, and have problems.

FYI, 9mm ejectors are slightly bent