PDA

View Full Version : Weak striker on XDSC9?


Lugiahua
02-21-2012, 12:41 PM
I recently bought a new XDSC-9, ran about 400 Winchester Ranger +P rds so far.
But I notice that sometimes the striker failed to discharge the round, leaving a small dent on the primer.

I have to rack the slider and re strike the primer to discharge it.
My current hypothesis are:

1. The weapon haven't break in.
2. The striker spring is too weak, require armorer service/better spring
3. Winchester Ranger has harder primer

What do you guys think? Should I send this firearm to a armorer with a stronger spring? Or shoot more to break in it?

Jimmy310
02-21-2012, 9:59 PM
i had a xdsc9 made in 2008 that was flawless. Does it hang up on other kinds of ammo? Does it only do this after many rounds? are the primers brass or stainless colored? Either way, being a "slav-glock", it should fire hard primers with no trouble.

G60
02-21-2012, 10:12 PM
Try different ammo, first of all.
But usually Ranger of all types is GTG.
If you experience the same thing, send it back to springfield, don't waste your money when the gun should work right in the first place.
It should not require a break-in period.

zfields
02-21-2012, 10:15 PM
Did you accidently get oil in the striker channel.

I did that and had similar problems with CCI primers. Took out the pin and degreased it. Make sure its bone dry.

Not a problem since, that was about 4k rounds ago.

CombatDOC
02-21-2012, 10:33 PM
+1 on being dry.

XDSC9 since 2009 w/ no problems & over 2500 rounds.


Did you accidently get oil in the striker channel.

I did that and had similar problems with CCI primers. Took out the pin and degreased it. Make sure its bone dry.

Not a problem since, that was about 4k rounds ago.

monk
02-22-2012, 12:04 AM
I would agree with the striker channel check.

Lugiahua
02-22-2012, 1:32 AM
thank you guys,
didn't know that how dirty and greasy is my striker channel before lol
hope I will find out the problem this weekend.

Sturnovik
02-22-2012, 10:47 AM
Yea check the channel. The XD is a good build, I'm guessing its just foreign debris/matter thats causing issues.