PDA

View Full Version : for those who have built their own lowers


Mr_Monkeywrench
12-11-2011, 9:16 PM
Just curious, have any of you that have built AR 80% lowers either into pistols or rifles ever been hassled because of the lack of markings on the receiver from Leo's or forest rangers? Just wondering what your experiences have been.

h0use
12-11-2011, 9:28 PM
I have built both for pistol and rifle.Have never run into a problem. I do keep a copy of ATF print out thow just in case.

Yugo
12-11-2011, 9:32 PM
:popcorn:

Mr_Monkeywrench
12-11-2011, 9:34 PM
You wouldn't happen to have a link to that would you? Im sure there are a lot of members here that would like to keep a copy in their range bags.

GUNNTZ
12-11-2011, 9:39 PM
Never been confronted by anyone, what markings are lacking on your lower? Most only have a model, serial and manufacturers info. What else could they need, other than flow chart items. Your 4473 form/printout should suffice if it came down to that.

Mr_Monkeywrench
12-11-2011, 9:44 PM
Never been confronted by anyone, what markings are lacking on your lower? Most only have a model, serial and manufacturers info. What else could they need, other than flow chart items. Your 4473 form/printout should suffice if it came down to that.

Im speaking of those folks that have milled (or dremmeled for the braver ones) incomplete lowers into functioning lowers. In those cases, one does not need to put any identifying markings on it unless it is being sold.

Mr_Monkeywrench
12-11-2011, 9:48 PM
Never been confronted by anyone, what markings are lacking on your lower?
I sold my firearms in the for sale section here; with the exception of those that are sadly sitting on the bottom of the Pacific Ocean.

GUNNTZ
12-11-2011, 10:03 PM
Got it now, missed the "80%" part of your post. That seriously sucks about your firearms, well the salt will do them in quickly; their pain will be short. I think the ATF/DOJ has info on their sites for your instance.

Mr_Monkeywrench
12-11-2011, 10:37 PM
Thank you :D

MrPlink
12-11-2011, 10:44 PM
nope, never had a problem