PDA

View Full Version : questions for ar platform guru


justin4fun
10-13-2011, 8:23 PM
hello all have been trolling for some time. thanks for all the great discussions and info found here. new to the ar platform but not a gun noob. purchased a psa complete rifle the 16" moe and assembled on a st-15 lower.build was easy and rushed out for a range trip. at the range it worked great accept had a couple light primer strikes. barley marked the primer but if I sent them through again fired just fine. not sure what was causing this. went home and stripped it but found nothing unusual. first thought is because its new? after firing and cleaning noticed the charging handle is now much smoother and much more easy to opperate. was about to put it away but then I noticed the trigger was not feeling normal. after playing with it found that if I charge it (unloaded of coures) with the saftey in the fire position all was normal but if the saftey is on safe and I pull the trigger then switch to fire the trigger pull is twice as hard. my first thought is did I incorrectly install the fcg? have not yet disassembled the fcg. is it a deffective fcg and should be replaced? has anyone else experienced this? should I contact psa? thanks so much for your responses and input.

shark92651
10-13-2011, 8:28 PM
Did you perform a function check on your lower after you assembled it? Make sure none of the springs are backwards and the safety detent and spring are inserted correctly and that the disconnector and spring are ok.

OHW
10-14-2011, 6:40 AM
What Shark says.

Fiveohmike
10-14-2011, 6:47 AM
I disagree with shark...


.





.
.




just because I didnt post it first