PDA

View Full Version : LEFTIES! Ambi charge handle not working:NEED ADVICE


kemikalembalance
09-29-2011, 10:33 AM
I recently built an AR for friend. He wanted a ground up for his first rifle and we spent days going over all the different types. He is a reserve Marine so he has shot the basic M-16 but wanted his own to be built to his specs. The rifle turned out beautiful, but... he is a lefty and i found him an ambi charging handle from Armadynamics. It is very nice ch! He bought a Sun Devil upper/lower witch is nice as well. But it doesnt work in the Sun Devil upper. He is also using an Adams Arms gas piston system as well.
So. What ive done:
1. tried his ch in my Larue upper WITH Adams piston---works fine
2: tried his ch in my Bravo Co upper with Adams piston---works fine
3: tried his ch in my wifes Rainier DI upper---works fine
4: tried his ch in another DI upper i built---works fine

So. It worked in two other billet uppers, one DI, one Adams piston---works
It worked in two other forged uppers, one Di, one piston---works

ADVICE PLEASE. I havnt totaled the build, but he is in the rifle over 1500 dollars. I would really love it if ya'll might have some advice to get this to work. Thank you for your time.
http://i925.photobucket.com/albums/ad97/kemikalembalance/IMG_0630.jpg http://i925.photobucket.com/albums/ad97/kemikalembalance/IMG_0639.jpg
http://i925.photobucket.com/albums/ad97/kemikalembalance/IMG_0638.jpg
http://i925.photobucket.com/albums/ad97/kemikalembalance/IMG_0629.jpg
http://i925.photobucket.com/albums/ad97/kemikalembalance/IMG_0625.jpg
http://i925.photobucket.com/albums/ad97/kemikalembalance/IMG_0647.jpg

theneko
09-29-2011, 3:50 PM
As a lefty, I prefer the Badger Ordinance charging handle - it has a large scoop/handle on its left side. YMMV.

mif_slim
09-29-2011, 4:05 PM
Well, the only thing to do is sell it to me and I'll even add a normal CH in the purchase. ;)

On a serious note, maybe his gas tube/stripped upper is mid align somewhere?

21SF
09-29-2011, 4:11 PM
So from the pics it looks like it goes all the way in, hits, but doesnt go deep enough for the lock to engage on the left?

If so maybe file/sand the tip slowly and carefully to "shorten" it.

tomd1584
09-29-2011, 4:22 PM
thats the problem with billet uppers/lowers. Does a normal charging handle work in it?

EDIT: meant to say, have you tried different CH's in the sun devil upper? could be that the upper is out of spec.

SoCalXD
09-29-2011, 5:43 PM
I have the same charging handle on a SunDevil upper and it works fine with a gas tube (It's a great charging handle for a lefty!). That said, I've been reading that the Sun Devil Uppers are out of spec on the grip mount (doesn't fit well with the hammerhead grip, which I found out the hard way!), so perhaps there is an alignment issue with the receiver/piston? I would contact Adam's Arms, Sun Devil and ArmaDynamics to see if any of them have seen this issue.

kemikalembalance
09-29-2011, 9:11 PM
thats the problem with billet uppers/lowers. Does a normal charging handle work in it?

EDIT: meant to say, have you tried different CH's in the sun devil upper? could be that the upper is out of spec.

yes we tried one other. actually, all i run are BCM. they worked fine. still lost.

kemikalembalance
09-29-2011, 9:15 PM
I have the same charging handle on a SunDevil upper and it works fine with a gas tube (It's a great charging handle for a lefty!). That said, I've been reading that the Sun Devil Uppers are out of spec on the grip mount (doesn't fit well with the hammerhead grip, which I found out the hard way!), so perhaps there is an alignment issue with the receiver/piston? I would contact Adam's Arms, Sun Devil and ArmaDynamics to see if any of them have seen this issue.

very well may be. it was a helluva time pounding the shim in and the ch works fine without the gas rod installed. as best as my eye can see and as best as my level works, the upper and the gas block line up perfectly

kemikalembalance
09-30-2011, 10:18 PM
bump for help

Sky_DiveR
10-01-2011, 10:00 AM
Perhaps I'm alittle slow or I just missed it... but I don't see anywhere where you mention what exactly doesn't it do (other than it doesn't work). Perhaps alittle more clarification might get you more help?

SpeedTribe
10-01-2011, 10:34 AM
If it works (locks in?) without the piston rod I would look to make sure the piston rod is coming in straight and moves freely. Is the shim you had trouble with maybe a little crooked, which would cause the piston rod to be off center a bit, and it is interfering with the charging handle?

kemikalembalance
10-02-2011, 12:08 AM
Perhaps I'm alittle slow or I just missed it... but I don't see anywhere where you mention what exactly doesn't it do (other than it doesn't work). Perhaps alittle more clarification might get you more help?

works standard, but not from the right side. (ambi)

kemikalembalance
10-02-2011, 12:12 AM
If it works (locks in?) without the piston rod I would look to make sure the piston rod is coming in straight and moves freely. Is the shim you had trouble with maybe a little crooked, which would cause the piston rod to be off center a bit, and it is interfering with the charging handle?

as best as i can tell, the piston rod is straight and the shim is seated all the way. i had a friend look at it tonight and his conclusion is that the upper, gas system and the ch just dont mix. in a post above, they said that they were running a sun devil with the same ch and it worked fine. so i guess its just the combo he is running. thanks all for the help and input