PDA

View Full Version : Sig 522 won't eject live rounds?


Metal Magic
09-16-2011, 7:09 PM
I just realized today that my Sig 522 will not eject live rounds, I have never had a FTF with this gun and looking back I don't recall ever trying to eject a live round. This thing has run so flawless that I have never done anything but slap in a mag and shoot all 10 rounds till the hold-open popped up. Today tried to clear a round out and it stuck (barely) in the breech. A few more times with mixed results, sometimes they would almost cause a double feed, never fully ejecting.

So, I guess I am curious if this is typical or maybe it could be the ammo I am using? I am trying to run through a box of Winchester Super X I bought to try out. Oh yeah, I tried two different mags (BDM,CMMG) with no luck on either.

While I'm here I might as well through up a picture.

http://img.photobucket.com/albums/v412/Linden5150/sig522v2.jpg

MrExel17
09-16-2011, 8:42 PM
I can be wrong but I use CCI Mini mags thru my 522 and no issues at all! Give them a try, with the ammo you have I was told that you can run into issues. People even go far to tell me if you want to train to clear mags,FTFs this is the ammo to do so. Try out the CCIs! Nice pix, that reminds me I need to post my 522 on the Sig 522 forum, thanks for sharing and hope it helps!

surfNshoot
09-17-2011, 3:57 AM
Well, Either your extractor is not functioning right. your chamber is dirty. (how many rounds?) or the chamber is very tight. the only time i've had this issue is with my Kidd 10/22 barrel and this is because it is a match chamber and VERY tight. The extractor on the sig bolt is quite an overkill so I would try cleaning it first. if that does not fix it send it back to sig for repair.

Metal Magic
09-17-2011, 5:17 AM
Thanks for the input guys, I have about 650-700 rounds through this rifle, which almost all have been CCI. I just recently bought this Super X stuff and now I am wishing I had at least one box of CCI left to test with. I did just recently clean the gun so I doubt that is the problem. I will have to go buy a case of CCI after work today and see if my suspensions are correct and the ammo is to blame.

Metal Magic
09-18-2011, 7:18 AM
UPDATE: It was the ammo

MrExel17
09-18-2011, 9:48 AM
Nice glad it worked out:thumbsup: