PDA

View Full Version : A Couple MKII Questions


sneather
09-05-2011, 8:10 PM
I should probably post some of these questions on a dedicated MK-series forum, but I figure it can't hurt to try Calguns first.

Does anyone know whether the front and rear sights are interchangeable between the bull-barreled Ruger MKII and MKIII? I'd like to try some of the Ruger MKIII sights on my MKII.

Also. Was just firing the MKII over the weekend, and while it performed great, with zero jams or failures in 400-rounds, it DID have some weird malfunctions. Every so often, after the last round, the magazine would mysteriously unlatch and slide down a half-inch or so. That would prevent the bolt stop from engaging, which was annoying, but otherwise it didn't actually cause any issues with firing. I have the gun stripped down to every last spring, and I'm going to look everything over in the next couple days. But, the gun is really in perfect shape, so I don't know what was causing the magazines to occasionally pop free.

Anyone else experience the same odd thing before? Also, the magazines are regular factory Ruger affairs.

Thanks!

Fatcat
09-05-2011, 10:26 PM
If the gun is clean, it's possible the mag catch spring needs to be re-tensioned or replaced. Order direct from Ruger.com

Read and post your questions over here:

http://www.rimfirecentral.com/forums/forumdisplay.php?f=209

Tank 57
09-05-2011, 10:36 PM
I had an extended latch on my MKII.Resting the pistol on anything would release the mag.

sneather
09-06-2011, 7:41 AM
Thanks, guys. I still have the stock mag catch, and it's in like-new shape. The spring is quite stout, but there aren't that many options, so I may try picking up another spring from Brownell's. What's odd, is that while the problem happened more than a few times, it never actually caused a single feeding or ejection issue. That makes me think that somehow the mag springs might be a little stiff from lack of use, and combined with the force of the bolt coming home, it is enough to stress the mag catch open.

scootergmc
09-06-2011, 9:40 PM
I've read this thread and your other one on rimfirecentral. Are you positive the spring is in there correctly? And has the latch been modified/rounded in any way?