PDA

View Full Version : stag upper wont chamber last round?!


diegojosh
01-07-2007, 3:04 PM
Hello, happy sunday! Yesterday I took my new stag rifle to the range for the first time and I loved every second of it, but for some reason about every other magazine wouldn't chamber the last round. I put 80 rounds through it and on the last round of almost every mag the bolt would stay open as if finished and I would have to manually load the last round. This isn't normal is it? Any help would be great.

5968
01-07-2007, 3:15 PM
Sounds like a mag problem.

Ratters
01-07-2007, 5:40 PM
Yep, sounds more like a magazine issue.

SpeedTribe
01-07-2007, 6:24 PM
If you are running the Stag mag a few others have had issues with them. I think they fixed it by bending the feed lips properly. I recommend getting the Bushmaster mags.

Fjold
01-07-2007, 6:39 PM
Hello, happy sunday! Yesterday I took my new stag rifle to the range for the first time and I loved every second of it, but for some reason about every other magazine wouldn't chamber the last round. I put 80 rounds through it and on the last round of almost every mag the bolt would stay open as if finished and I would have to manually load the last round. This isn't normal is it? Any help would be great.

OK, I have to ask. Are you running your Stag rifle without the flash hider and pistol grip?

MotoGuy
01-07-2007, 7:38 PM
Same thing happends to my OLL when using stag mags... other mags work fine.

diegojosh
01-08-2007, 12:13 AM
fjold, I Have a pistol grip but also have a fixed mag (prince 50). Why do you ask?

Fjold
01-08-2007, 5:47 AM
fjold, I Have a pistol grip but also have a fixed mag (prince 50). Why do you ask?

Because you said;
"but for some reason about every other magazine wouldn't chamber the last round"

It sounded like you were using a number of magazines, which is usually assumed to be running without evil features.

Just trying to be cautious and protective of new users.

diegojosh
01-08-2007, 5:40 PM
Thanks for looking out for me Fjold. I was just trying to say that each time I loaded my rifle the tenth round would not chamber. From what everyone say it sounds like a mag problem. Thanks everyone!

Powersauce
01-08-2007, 6:12 PM
i was having similar problems with my C products mags. the last round would feed sluggishly. the bolt catch would also perform 'less than optimal'.

whats happening is either 1. the spring is not giving enough response. or 2. the follower itself is getting caught on some part of the magazine. just get another, or you can modify the one you have to work.

it might not be as easy for you; but for my C products All i did was remove the floor plate, take the spring, flip it around and re-install. works alot better! the factory seems to favor installing them backwards for some reason

anyways good luck+1 but not from me... I just went to the range with a friend that just completed a build and he had a C prod mag. I told him the C Prod mag works fine for me and I also gave him the link where I bought it. He supossedly bought the same one but it was different.. It was shorter so it sat flush w/the receiver..kinda made it look like a FAB 10...the follower seem pretty inexpensive as well. I have the C prod mag with the orange magpul follower. Just slightly longer than the magwel