PDA

View Full Version : Converted saiga hammer won't lock back. (Fixed with pics.)


philthy209
05-29-2011, 12:00 PM
I have a converted saiga with Tapco single hook trigger. I took it to the range yesterday and it would not fire. I noticed the hammer was not locking down when i charged the bolt. Any ideas? What more info would you need to help me out. If i push the hammer down with my finger the trigger catches it but it will not fire. Help a newb out. Thanks. I can make a quick vid or pics of that would help. Thanks guys.

-Phil

The hammer was in backwards.:TFH::iamwithstupid:

rpotter94
05-29-2011, 2:18 PM
visit youtube type in Saiga conversion.. Your info will be on there..

tujungatoes
05-29-2011, 2:20 PM
I'm gonna guess the hammer is in backwards. Pics please.

imarangemaster
05-29-2011, 2:35 PM
+1 Hammer is backwards

Somekindagenius
05-29-2011, 6:07 PM
I had a similar problem once when I forgot to put my disconnector spring in.

pyro3k2
05-29-2011, 10:04 PM
+1 Hammer is backwards

I'm gonna guess the hammer is in backwards. Pics please.

another +1

philthy209
06-01-2011, 7:08 AM
pics coming after work sorry i've been offline my home PC is broke.

philthy209
06-25-2011, 5:32 PM
Hammer was in backwards. Here's picks of the complete conversion. (still need to thread the barrel but done for now.) Polished the bold carrier last night looks better in person i have a crappy camera and crappier photography skills.
http://i213.photobucket.com/albums/cc232/philthy209/079.jpg
http://i213.photobucket.com/albums/cc232/philthy209/084.jpg
http://i213.photobucket.com/albums/cc232/philthy209/081.jpg