PDA

View Full Version : Slooooooooooow non-fire


OC-Indian
12-31-2010, 1:55 PM
Tried to shoot my M44 and when the trigger is pulled it operates so slooooooowly it doesnt have enough force to fire. Everything cycles just fine and I dont know enough about these to spot whats wrong. So where do I start?

armygunsmith
12-31-2010, 1:56 PM
Cosmolone in the bolt? Did you completely disassemble and clean it?

mosinnagantm9130
12-31-2010, 1:58 PM
Cosmolone in the bolt? Did you completely disassemble and clean it?

That's my first guess. Take the bolt apart and clean the internals, if you haven't already.

morrcarr67
12-31-2010, 2:33 PM
Cosmolone in the bolt? Did you completely disassemble and clean it?

+1 on the Cosmoline :kest:

finloq
12-31-2010, 3:59 PM
http://7.62x54r.net/MosinID/MosinDisassembly.htm

cruddymutt
12-31-2010, 4:24 PM
I got an m24/47 that was the same way when I took it out of the box. It was caked full of cosmo.

Interloper
12-31-2010, 5:20 PM
Also, you need to check the firing pin run-out, especially after you disassemble the bolt to clean it. Did you get one of the little tools with your carbine?

stitchnicklas
01-01-2011, 12:42 AM
cosmo.....

finloq
01-01-2011, 12:43 AM
Cosmo and Borscht

johnthomas
01-01-2011, 12:47 AM
http://surplusrifle.com/finnishmosin/boltdisassembly/index.asp

Dr.Mauser
01-01-2011, 2:59 PM
You may need a new firing pin, or spring, or both

OC-Indian
01-03-2011, 7:02 PM
Thanks everyone. I'll clean the crap out of it and see if that helps

cruddymutt
01-03-2011, 8:59 PM
Thanks everyone. I'll clean the crap out of it and see if that helps
For bolts I like to disassemble them and boil the cosmo off in water. Makes it easier to get the cosmo out of the tight spots. Dry completely and oil it well and then reassemble.