PDA

View Full Version : Computer problem, file extensions incorrectly assigned?


xrMike
11-05-2010, 1:41 PM
I don't know what the heck my daughter did to our upstairs desktop system. It runs XP. I haven't scanned it for virus yet, but Norton is saying it's good to go (with a green checkmark), although I have not done a full system scan yet. I'm hoping it's something easier to fix.

All of the icons on the desktop with a .EXE (executable) extension are now associated with Microsoft Word, and are displaying as Word document icons. So when you try to run any app, it opens up Microsoft word instead, with an error message saying "Don't recognize this file type."

Now my 1st idea to fix this was to go into Windows Explorer and reset the file association correctly. Except there are 2 problems with that. 1) When I try to run WinExlorer, Word opens up (because it too is an app -- d'oh! :D), and 2) even if I could get it to run, I don't know the name of the file/app that windows uses to run apps (.EXE files)...

What is the right way to fix this problem?

Thanks very much.

Ricky-Ray
11-05-2010, 2:03 PM
Double click on My computer and select Tools, Folder Options, File Types. Scroll down till you find the .exe extension and then delete it.

Uriah02
11-05-2010, 2:05 PM
Or...
right click the .exe and click "open with", uncheck the box "always open with this selection" or something like that and that might help.

xrMike
11-05-2010, 3:04 PM
Double click on My computer and select Tools, Folder Options, File Types. Scroll down till you find the .exe extension and then delete it.

Did this, but .EXE does NOT appear in the list of available file extensions. There's a million other file types in the list, but no .EXE. To see if this is normal, I checked the same thing on the XP laptop I'm using now, and it's the same there... .EXE does not appear in the list. So I'm thinking that must be normal.

Or...
right click the .exe and click "open with", uncheck the box "always open with this selection" or something like that and that might help.

Tried this too. When I try to "Open With" on the Windows Explorer program, I get a list of programs to choose from. WinExplorer is NOT in that list, so I click Browse button. I find the file "explorer.exe" in the Windows directory, and try to open the shortcut using that file. The app does not run. Instead I get a "File download" box, as if it were trying to download a file from the net, with an Open or Save button. Opening it does nothing except bring the same box back onscreen. Only now, ALL of the icons that formerly had Word icons associated with them now have WinExplorer icons instead.

Appreciate any other suggestions. I'm running full system scan now, with latest update file...

Also, what is a .LNK file? That's a shortcut, right? Could it be that the .LNK association is what is wrong?

Last question: How do you tell windows to revert ALL file associations back to their default values? That would probably fix the problem also...

Thanks.

Ricky-Ray
11-05-2010, 3:27 PM
Did you try using system restore and restore to a previous date before this happened? Maybe that would fix it.

Ricky-Ray
11-05-2010, 3:29 PM
I did a quick google search and it looks like the .exe is controled in the registry. This looks like it should get you back up and running normal again.

http://filext.com/faq/broken_exe_association.php

xrMike
11-05-2010, 5:02 PM
Ricky-Ray, thanks a TON! for that link... it seems to accurately describe the problem I'm having, especially this part:

A symptom of this often appears as shortcuts become .LNK files where the .LNK extension shows up and none of them work.

That is what's happening, although I did not make that clear in the original post...

Can't do it right now, but I will try the methods described in your link later tonight or tomorrow morning, and post results here. Thanks man!

JDay
11-05-2010, 5:59 PM
This page has file association fixes for XP.

http://www.dougknox.com/xp/file_assoc.htm