PDA

View Full Version : AR Feeding Issues


sfonelson
09-28-2010, 11:48 AM
Brand New, Lubed, BCM gov 20 upper.
Two different 10/20 PMAG's.
JDMachine Lower with RRA single stage parts kit.
Raddlock
Crappy Brown Bear Steel Case Ammo

On several instances, always seemed to be the last or second to last round in the mag, the tip of the bullet would get caught up on the TOP of the chamber opening.

Weird, every round up to the second to last or so would cycle fine.

Same ammo and same pmags work flawlessly in my other AR, which is a GG&G dominator-1 upper, and same lower setup.

I saw another post about not tightening up my raddlock too much. I to have it pretty tight. I will loosen it and see if that does anything.

Since this is the cheapest of the cheap ammo, that probably doesn't help either.

Thanks in advance for any other advice you guys have!

bjl333
09-28-2010, 12:01 PM
Try out different mags and see if the problem is still there.

C_1
09-28-2010, 1:41 PM
Is the BCG oiled well? But its probably the PMAGs. Try some standard 10rd mags and see if it'll work. Lots of great into in the other thread, so you should try all that stuff too.

sfonelson
09-28-2010, 1:45 PM
Completely coated. Yeah, I am going to try some regular 10 rounds mags. Looks like more stuff for me to purchase... =(

I'm going to check the raddlock too.

Is the BCG oiled well? But its probably the PMAGs. Try some standard 10rd mags and see if it'll work. Lots of great into in the other thread, so you should try all that stuff too.

FeuerFrei
09-28-2010, 4:36 PM
AR feeding issues I have encountered usually are resolved with;
*Swapping out the mag for a "known good" mag.
*Clean the chamber with an "AR" chamber brush before you shoot.
*Grease the 4 contact points on the carrier and the *** end of the bolt/ring area.
This usually gets you going again with any ammo you feed it.