PDA

View Full Version : Aimpoint Micro T-1 Problem


bluebum
09-13-2010, 2:39 PM
Hi all. I took the AR out yesterday to zero my Micro T-1 that i purchased used on this sight about a month ago. I'm pretty certain its a real Aimpoint (i checked multiple threads on identifying real vs. fake). Problem was that after every shot, the red dot would disappear. After I gave the T-1 a couple strong taps with my finger, the red dot would appear again. Shoot again, and the red dot disappeared. I read a couple threads on how the battery cap might need to be tightened so i tried that and dot kept disappearing after every shot. Any suggestions on whats going on? Can i send it out to Aimpoint under warranty even if i bought the product used? Please advise.

CoyoteHunter555
09-13-2010, 2:47 PM
Shove some foil in behind the battery cap, IF you want to avoid returning it. See if that works. Several warranties only apply to the original owner, but I am sure Aimpoint would repair/replace a lemon

tomd1584
09-13-2010, 2:53 PM
Aimpoint will fix it even if you're not the Original owner. I have a contact over there, the Customer Service manager. He replaced a used H1 i had bought over on M4carbine.net, ended up sending me a brand new T1.

Before sending it, take the battery out, put a fresh one in, and tighten the battery cap with a coin. It might just fix it.

if it doesnt, PM me if you'd like to get in touch...

bluebum
09-13-2010, 3:17 PM
Aimpoint will fix it even if you're not the Original owner. I have a contact over there, the Customer Service manager. He replaced a used H1 i had bought over on M4carbine.net, ended up sending me a brand new T1.

Before sending it, take the battery out, put a fresh one in, and tighten the battery cap with a coin. It might just fix it.

if it doesnt, PM me if you'd like to get in touch...

I'll definitely try a new battery. If problem persists, i'll ask you for your contact at aimpoint. Appreciate the offer! Thanks.