PDA

View Full Version : "Feeler" Thread for one of my K98s


AngryPossum
04-17-2010, 2:30 PM
I've noticed some of these "feeler" type threads for those of us thinking about trying to sell/trade one of our rifles. I just figured I'd put this out there to see if there might be any interest or some info on where to start troubleshooting it. I'm still not sure yet what I'm going to do with it, so I'm not ready to post it in the for sale section.

I bought some K98s off a buddy of mine a while back. All Russian captures. I picked out the best one for myself and I bought this one here because I wanted one to "play with". The stock is different then most RC's I've seen. This rifle came from J & G (I think) and it appears to have been sanded, but never finished? I can't bring myself to refinish any of my other rifles, so I thought I would have some fun with this one since it appears to have been sanded down already. Months have passed and I haven't got to it yet. Sorry for the crappy pics...still figuring out the new camera.

It is a "CE" "43" K98. I've shot it once to test function. I used some Romanian surplus and after about 5 flawless rounds...the firing pin was not able to puncture the primers....it seemed to happen about 2-3 times out of every 5 rounds. I put it away and I havent messed with it since. I do not think it's a big problem though. I think it might be the ammo, because it happened on my other k98 as well then it stopped....and its been a flawless tack driver since. This one however continued to do it. I plan on looking into it as soon as I can get some time to shoot. I'd like to get it functioning 100% before I sell/trade it. Anyone have any Ideas on where to start to isolate the problem?

http://i953.photobucket.com/albums/ae14/Angry_Possum/004.jpg?t=1271539620
http://i953.photobucket.com/albums/ae14/Angry_Possum/009-1.jpg?t=1271539658
http://i953.photobucket.com/albums/ae14/Angry_Possum/005.jpg?t=1271539706
http://i953.photobucket.com/albums/ae14/Angry_Possum/012.jpg?t=1271539732
http://i953.photobucket.com/albums/ae14/Angry_Possum/007.jpg?t=1271539759
http://i953.photobucket.com/albums/ae14/Angry_Possum/013-1.jpg?t=1271539822

Mssr. Eleganté
04-17-2010, 2:41 PM
The cheapest thing to try would be disassembling the bolt and cleaning it out really good. Next would be a new striker spring. You could first try using the striker spring out of a known sure-fire K98.

tankerman
04-17-2010, 8:59 PM
The cheapest thing to try would be disassembling the bolt and cleaning it out really good. Next would be a new striker spring. You could first try using the striker spring out of a known sure-fire K98. I agree. Fitting a new firing pin can be a bit of a headache.

Plywood
04-17-2010, 10:36 PM
Make sure your firing pin protrudes 0.055"-0.065" My K98 had the same issue. I replaced the pin and now every round goes bang. I shoot both Romanian and 50's Yugo surplus with no problems.
Sweet k98 by the way.