PDA

View Full Version : glock question


roor1200
02-24-2010, 5:00 PM
hey guys,
my g19 so far has run like a champ until recently taking it out to the range i noticed after every shot the slide would lock back and not chamber the next round. i first thought it might be the ammo then i realized after each shot the slide release was a bit loose and from the recoil it would lock the slide back. if i held the slide while i fired the pistol, it would function properly...
now on to my question, am i missing a spring or part? and what would i need to replace or install? thanks in advance...

Untamed1972
02-24-2010, 5:04 PM
Are your magazines getting worn perhaps? did it do with different mags in it, or just the same mag?

roor1200
02-24-2010, 5:18 PM
i used different mags and the same thing....

Voo
02-24-2010, 5:20 PM
Did you recently take it apart??

If the slide release is not properly installed "SECOND" after the pin, it can lock your slide back intermittently..

In any case, I would field strip your glock and check to make sure the slide stop spring is still intact and properly installed.

There's a bunch of Youtube videos regarding this..shoudlnt take you anymore than 10 minutes to fix (if it was this)

SCMA-1
02-24-2010, 5:56 PM
Did you recently take it apart??

If the slide release is not properly installed "SECOND" after the pin, it can lock your slide back intermittently..

In any case, I would field strip your glock and check to make sure the slide stop spring is still intact and properly installed.

There's a bunch of Youtube videos regarding this..shoudlnt take you anymore than 10 minutes to fix (if it was this)

+1.....a common occurrence with Glocks if you are not careful on re-assembly.

someR1
02-24-2010, 6:00 PM
yep....field strip and make sure all parts are properly installed and clean.

RickD6023
02-24-2010, 7:46 PM
This is not an uncommon occurrence. Had it happen with my G22 after around 8500 total rounds down the pipe. I detail stripped my frame to get to the slide release. I noted that the spring was curled to match the end of the release - it was worn out. I was able to rebend it and it lasted another 200 rounds before it gave up the ghost. In the meantime I got replacement slide releases from member of another forum for $5 each (plus a total of $5 shipping). This is an inexpensive fix and took me less than 5 minutes to do the swap out and cleaning. The YouTube videos show it well. Here's one on the G19:
http://www.youtube.com/watch?v=d-qAQPFpRZQ

Ultimate
02-24-2010, 10:28 PM
Sounds like the slide release is not installed properly. Remove the top mid frame pin first, then the second. Reassemble by installing top mid frame pin first then the second one.

If you put in the second pin in first the top pin can squish the spring and not allow the spring to rest on it properly.

roor1200
02-25-2010, 11:51 PM
thank you guys!:D