PDA

View Full Version : Problem with S&W 629


luchador768
08-14-2009, 5:17 PM
The cylinder on my new 629 is VERY sticky. It takes a fair amount of force to get it to open. Should I go directly to S&W or to a local smith?
Thanks in advance,
Peter

c good
08-14-2009, 5:26 PM
How many rounds through it? Also, sticky after cylinder disengages and swings out or just sticky to get it to unlock? First check for gunk under the extractor star. Then check to make sure ejector rod is tight (reverse thread). Then check that thumb cylinder release screw is tight. Next make sure cylinder bolt/plunger? (spring loaded thingy on extractor star that locks into frame) is lubed and plunges freely. If all these don't correct problem, send it back to S&W, especially if it's new. HTH c good

luchador768
08-14-2009, 5:29 PM
Zero rounds, my baby is brand new. Nothing appears to be binding. I will go on a tightening mission tonight.
Peter

SCMA-1
08-14-2009, 5:29 PM
It's usually the ejector rod that loosens and backs out; like the previous guy said, it's reverse threaded.

SCMA-1

c good
08-14-2009, 5:33 PM
I put a little dab of grease on the cylinder plunger thingy and also on the front of ejector rod where it locks into the frame. Check the front frame plunger pin too to see if it's lubed. I use a little oil on this one to help it go into the frame nice and smooth. HTH c good

luchador768
08-14-2009, 6:17 PM
Another problem solved by CalGuns.net! Thanks again fellas!
Peter

SCMA-1
08-14-2009, 6:19 PM
Another problem solved by CalGuns.net! Thanks again fellas!
Peter

Excellent! Now go shoot that puppy and let us know what you think.;)

SCMA-1

c good
08-14-2009, 7:51 PM
Good Going! What was causing the trouble? (loose ejector rod right?) c good

luchador768
08-14-2009, 8:56 PM
Good Going! What was causing the trouble? (loose ejector rod right?) c good

Ding Ding!