PDA

View Full Version : Sig p226 9mm w\22lr kit jamming....


widebodym3
07-31-2009, 11:03 PM
Hello-

just bought a brand new sig p226r 9mm and I also bought a factory sig 22lr conversion kit...

Took them both out today to pop their cherries...the stainless 9mm barrel worked beautifully...BUT...

When I switched out to the 22lr barrel every 2 to 3 rounds "Nina" would jam up and I would have to clear the chamber. I also noticed that rounds were not being "grabbed" from the mag sometimes.

I am using Winchester 22lr high velocity ammo...and factory sig mags (sig logos but built by mec gar)

Really appreciate any pointers here...or even the hard truth...like I bought the wrong setup...

Thanks

Jonathan Doe
07-31-2009, 11:11 PM
I have one and used standard velocity ammo from different companies without a single jam. Make sure the rails and other parts are properly lubricated.

trashman
07-31-2009, 11:14 PM
Two things -- I have a P220 kit and have sent it back to Sig twice.

1) It *hates* the Winchester .22lr ammo. Won't function for @#$!

2) Sig replaced my mag catch because it was wearing out the notch on the plastic magazine -- so even with non-Winchester ammo the magazine would back out during cycling -- preventing the slide from stripping a new round, and loading it into the chamber.

I like this kit a lot -- but for ~$300 I am *very* disappointed in the plastic mag.

--Neill

s*******n
08-01-2009, 11:08 AM
Hi - I have several suggestions, but too long to post. Sent you a PM.

bsg
08-01-2009, 7:26 PM
i have been told and read that this setup has been problematic from the gate. i have long been interested but am still resistive and so far... a non believer.

Gregchico
08-01-2009, 8:37 PM
My 226 conversion has been near perfect from day one. Federal and CCI ammo seem to work the best for me. It chokes on Remington, and runs poorly on most others I have tried.
I do not think it is a "set up" problem only an ammo problem. 22lrs can be very particular....

liketoshoot
08-01-2009, 8:41 PM
^^^^^^^ I too have not had any problems, yet.
I do have the occasional FTE and some FTL the next round but it is more the ammo then the gun, mine uses the bulk packs from WW. most of those are rated at 1280 fps and they are great but all guns are differant.
Make sure you over lube the rails this might help.

Iknownot
08-01-2009, 9:33 PM
My kit worked for the first 40 rounds and then the firing pin gouged out a divot into the chamber, causing failure to feeds there after.

I shipped it off to sig for warranty work, on their dime, both ways, and after coming back, the kit works pretty much flawlessly.

It will run 100% with the recommended hi velocity 22lr and will have a failure to feed here or there running cheapy walmart 22lr, of which, I have no real complaints.

I can run pretty much any 22lr ammo with good reliability and only a FTF here or there.

rp55
08-01-2009, 9:36 PM
I have one and have put around 300 rounds through the 22 kit with no issue. All of them were CCI Mini Mags, as recommended by SIG.

widebodym3
08-01-2009, 9:43 PM
Thanks for all the pointers....

In no particular order I'll try:
cleaning and over lubing the rail
cci mini mag ammo
if all else fails...a doa conversion kit will be back at sig's door step