PDA

View Full Version : New to Me S&W 4566 has a clicking problem


1step
05-14-2009, 10:07 PM
I took pocession of a 4566 this past Sunday Looks barely used by Fresno PD. But there is one issues: in SA there is a "click" sound and feel to the trigger about half way through the pull. I video'd the problem with and without the slide installed. DA is smooth. I have yet to fire this pistol and want to make sure it's safe to do so. Any ideas?
http://i175.photobucket.com/albums/w155/1stepp/SW/th_4566click.jpg (http://s175.photobucket.com/albums/w155/1stepp/SW/?action=view&current=4566click.flv)

69Mach1
05-14-2009, 10:14 PM
Don't know what that is, but looks like your magazine disconnect safety was deactivated. Maybe something to do with that.

aplinker
05-14-2009, 10:32 PM
You AIM friend is getting impatient. Put the gun down and talk to him.

trapshot68
05-14-2009, 10:33 PM
My NIB 4566tsw did the same thing. Friend's duty 4566tsw also did the same thing. You can see the trigger shifting around when you take the slide off.

I got rid of the click, but I can't be for sure what I did to remedy it.

http://www.brownells.com/Images/Schematics/sw-dacenterfire.gif I think on part #7 (trigger bar), I took off that spot welded tab (#66) on the top side there.

1step
05-14-2009, 11:05 PM
Don't know what that is, but looks like your magazine disconnect safety was deactivated. Maybe something to do with that.

With the slide on, the magazine is required to be inserted. With it off, there seems to be no need.

trapshot68
05-15-2009, 8:03 AM
yeah, the mag disconnect is part #20 and housed in the slide.