PDA

View Full Version : Need to replace firing pin/others on HK USP 9 compact (technical help)


cbn620
02-28-2009, 6:43 PM
Hey folks. My uncle needs his USP fixed post haste. I have a knack for fixing firearms though I am no gunsmith, and decided I'd give it a shot at helping him so he doesn't have to pay a gunsmith. I have worked with many firearms models and have a lot of experience with various non-firearms related mechanisms but am not terribly familiar with H&K's.

Basically the firing pin needs to be replaced. This is a used model. A few years ago during shooting he had the firing pin and a few other parts come flying out the back of the slide and into the grass and dirt, never to be found again. He had put it off but now it's high time to get it fixed.

My first priority is figuring out how to remove the firing pin, bolt and ejection assembly from the slide. Second priority from there is figuring out what parts are missing.

I figure if you folks can help me with the process of disassembling the firing pin assembly, I can show you all what parts I have and you might give me some advice on what parts I need. If any of you have a schematic or armorer's manual I could take a look at, I'd much appreciate it.

Time is of the essence here as we need this pistol operational before the end of the month (March). Thank you very much for your time and consideration.

LazyAndy
02-28-2009, 8:26 PM
Here's a link to detailed disassembly

http://hkpro.com/forum/showthread.php?t=41104

Basically all you need to do is to punch out those roll pins that you see on the slide. The one closest to the extractor retains it. The rear roll pin retains the firing pin and firing pin block. Once that is removed, you need to push up on the firing pin block which will dislodge the firing pin (make sure you remember how it was oriented).

cbn620
03-01-2009, 10:16 AM
The firing pin itself is gone, so my job is to reinstall it. How is the firing pin re-installed? I am assuming I will have to put it in under spring pressure and insert the retainer pin located on the slide.

And what about the firing pin block? Part no. 12 here: http://www.lesales.com/parts_catalogs/HK_USP_USPC.pdf On his pistol, the firing pin and firing pin block are removed. We do not have the firing pin or firing pin spring, but we do have the firing pin block and firing pin block spring. How is this part installed?

Thanks very much for your help.

LazyAndy
03-01-2009, 3:15 PM
Here are some pictures of my slide to show you the proper orientation of the firing pin and firing pin block.

http://onfinite.com/libraries/1458540/244.jpg
This is where the firing pin block will go into on your slide, along with its spring.



http://onfinite.com/libraries/1458541/969.jpg
This shows the proper orientation of the firing pin. Note that the flat looking side is facing to the right.


So to put the firing pin back in, you simply insert it and the spring into the channel leaving a bit protruding. Then you insert the firing pin block spring and firing pin block. From this point you want to get the roll pin started from the bottom of the slide. Finally, you depress the firing pin block all the way and while simultaneously pushing in the firing pin until its flush while making sure the orientations of the parts stay the same. Once that is accomplished, you can finish driving the pin home and that should do it.

dexter9659
03-01-2009, 8:47 PM
i sent mine back to HK and had mine back with new springs, firing pin, extractor, mag release, pins and all. Free of charge in 4 days. A road you may want to explore.

cbn620
03-16-2009, 9:19 PM
Hey guys, just bumping this to say thanks to everyone for the awesome help. Unfortunately we are having the hardest time tracking down the parts. It would seem that's going to be the difficult part. The pistol is sitting in a long time family friend and trusted gunsmith's shop where they are trying to get parts for it. If anyone's got any connections as far as parts are concerned, now would be the time to mention it, but otherwise you can just consider the issue resolved.

Again thanks to everyone for the awesome and prompt help.