PDA

View Full Version : First build test driven today!


trg-s338
11-02-2008, 10:04 PM
At Lytle today, 120 rounds sent downrange to check my AR for bugs. Bushmaster Dissipator upper shot great except for an occassional failure to eject case jammed in with the new round being brought up the feed ramp. BCG well lubed prior to firing rifle, all clean for this first run. What causes this problem? Do I need an enhanced extractor spring and/or the Crane-O ring or is this just part of break in and expected. Should I continue to use until 500 rounds and then make a judgement on the problem or is that not a good idea. I would say in the 120 rounds it happened about 5 times. Any tips? Thanks.

Mississippi
11-02-2008, 11:41 PM
Had the same problem. Added the enhanced extractor spring kit and black bushing (instead of the blue one). Fixed my issues.

thy95
11-03-2008, 12:16 AM
i feel like i got to do this:useless:

Steve O
11-03-2008, 12:36 AM
Had the same problem. Added the enhanced extractor spring kit and black bushing (instead of the blue one). Fixed my issues.

Just got a new bushey my self. haven't had a chance to shoot it yet.
So what is this upgrade kit? Is there any links for install?

aplinker
11-03-2008, 12:42 AM
upgrade the extractor spring, insert and add an o-ring.

Like this:
http://www.gandrtactical.com/cgi-bin/commerce.cgi?preadd=action&key=CRN-BCM&reference=/cgi-bin/commerce.cgi%3Fsearch%3Daction%26keywords%3D%26sea rchstart%3D0%26template%3DPDGCommTemplates/FullNav/SearchResult.html%26category%3DBCOM

You might also consider heavy buffers for those carbine gassed guns.

Next time, buy mid-length - they don't need the carbine fixes, are more reliable and aren't as hard on parts.

scubamark13
11-03-2008, 9:08 AM
This is what I put on all my OLL and they haven't had a single extractor problem since. Trust me it's worth every penny!

http://www.mgimilitary.com/store/index.php?main_page=product_info&products_id=4&zenid=2a9c9c8f7dad7daf16907bd7459964a0