PDA

View Full Version : sig 225/p6 extractor problems


milsurpshooter
07-05-2008, 9:23 PM
well my 225/p6 keeps stove pipeing and double feeding. dosen't matter if i clean it or oil it. that only seems to fix for a couple of mags and bam it starts back up again. any ideas? thanks

JTROKS
07-05-2008, 9:39 PM
What kind of ammo are you using?

atasty39
07-05-2008, 9:42 PM
Not trying to be a smart a**, but there is a thread that discussed replacing all the 20 or so year old springs with new ones that takes care of the problem. Sorry I can not provide a link, but others were having the same issues. YMMV

ke6guj
07-05-2008, 9:47 PM
SIG P6/P225 Rearsenal Kits @ $19.50 (http://www.calguns.net/calgunforum/showthread.php?t=98207)

milsurpshooter
07-06-2008, 12:48 AM
i just changed all the springs a little while back. and i'm using all kinds of differnt ammo. so i really don't know whats going on.

loosewreck
07-06-2008, 4:50 AM
Top Gun Supply also carry great rearsenal kits.

However, I would suspect that your problem would be fixed with a fresh recoil spring and mag springs, as well as to sticking to 115gr ball ammo.

Also wouldn't hurt to change the extractor, they've got 'em at Brownells.com. Good luck.

duenor
07-06-2008, 5:02 AM
Swap springs (recoil, FP, mag), and clean gun thoroughly. a picture of your malf would help.

milsurpshooter
07-06-2008, 4:25 PM
Swap springs (recoil, FP, mag), and clean gun thoroughly. a picture of your malf would help.

well what it does is, i will fire a round and it will get half way extracted and caught on the fresh round underneath it in the mag. the only way to clear it is drop the mag and tilt the gun up and the spent case just falls out. so i think that i will change the extractor and see what happens. thanks for all the help everybody.:p

Guntech
07-06-2008, 7:16 PM
Sounds like extractor same thing happened with one of my guns I didn't notice the extractor had been sheared off